Cloud Archiving Service - US region only - Missing Audit Logs
Incident Report for Barracuda Networks
Update
Thank you for your continued support as we advance with the migration of our Cloud Archiving Service to the Public Cloud. We are actively working to minimize the disruption and aim to have the service fully operational, enabling the restoration of audit logs in the user interface, as soon as possible. We will provide more specific timelines as our work progresses and milestones are achieved.
In the interim, for any audit log requests, please continue to contact our support team.
We appreciate your patience and understanding during this process and want to assure you that we are committed to resolving this promptly and effectively
Posted Apr 24, 2024 - 17:11 UTC
Monitoring
To our US Customers,

We want to thank you all for your continued support and patience while we work through this issue. We understand the inconvenience that this is causing and want to assure you that we are working as quickly as we can to resolve this. Over the next few months our engineering team is going to be completing work on the migration of the Cloud Archiving Service from the Barracuda Cloud infrastructure into the Public Cloud. Once we have the service fully functional in the Public Cloud, we will be able to begin to restore audit logs back into the UI. As of today, we are trying to maintain a target of March 2024 for the US region. As we continue to check off on the remaining work required to reach a migration ready state, we will be able to share more defined timelines.

In the meantime, we will ask that you continue to call into support if you need a copy of audit logs that pre-date Nov 17th, 2023.

Thank you again for all of your patience during this time and please know that we hear you.
Posted Dec 13, 2023 - 15:54 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 17, 2023 - 07:48 UTC
Identified
We are aware that customers in the US are not receiving any results when conducting an audit log search with a date that is previous to Nov. 17th, 2023.

We understand the frustration that could cause and assure you that our team is considering a number of options to provide a complete and seamless solution to this issue.
  
During this time, should you require any audit log that predates November 17, 2023, please reach out to our dedicated customer support team. They will be able to facilitate retrieving a complete copy of your audit logs.

We sincerely apologize for any inconvenience that this may cause to you. We will provide any updates as we soon as we can.
Posted Nov 17, 2023 - 07:46 UTC
This incident affects: Cloud Archiving Service (Web Interface).