Barracuda XDR - Service Disruption

Incident Report for Barracuda Networks

Resolved

This incident has been resolved, and the impacted services are fully operational.
Posted Sep 22, 2025 - 18:29 UTC

Monitoring

Our engineering team has successfully implemented a solution to address this issue, and we will continue to monitor the situation to ensure that the affected services remain fully operational.
Posted Sep 22, 2025 - 17:16 UTC

Identified

Barracuda XDR has encountered an issue with events ingestion and signals detection, which may result in delayed ingestion and signals generation. Our engineering team has identified the root cause and is diligently working on a resolution. We understand the potential impact on your business and are committed to restoring full functionality as swiftly as possible. We will provide further updates once the solution is in place. Thank you for your patience and understanding.
Posted Sep 22, 2025 - 16:01 UTC
This incident affected: XDR (XDR Service).