Barracuda Appliance Configuration Backup to Cloud – Service Disruption

Incident Report for Barracuda Networks

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2025 - 13:46 UTC

Investigating

We are currently investigating an issue where some customers may see the error message "File upload failed" when attempting to back up their Barracuda Appliance configurations to the cloud. This may result in configuration backups not completing successfully. We will provide an update as soon as more information is available.
Posted Aug 04, 2025 - 18:38 UTC
This incident affects: Appliance Control (Cloud backups).