Barracuda XDR - Service Disruption

Incident Report for Barracuda Networks

Postmortem

Following a comprehensive investigation, we have determined that the root cause of the issue originated from receiving O365 events with future-dated timestamps from certain partners. This anomaly adversely affected the deduplication process during the ingestion of O365 events. Although our engineering team successfully resolved this issue on Friday evening, we experienced a loss of O365 events between 8:05 AM and 6:20 PM ET on Friday, August 1st. We have commenced the reingestion process for the missed events; however, please be aware that this may trigger alerts for these historical events. We sincerely apologize for any inconvenience this may cause to your business operations

Posted Aug 05, 2025 - 21:47 UTC

Resolved

Our engineering team has worked with Datalake cloud vendor to implement a solution to address this issue. Post the fix rollout, o365 events ingestion process is fully operational in these 2 impacted regions.
Posted Aug 01, 2025 - 23:00 UTC

Investigating

Barracuda XDR is currently experiencing an issue with the ingestion of O365 events, which may cause delays and affect customers in the US and EU regions. Our engineering team is diligently collaborating with our Datalake cloud vendor to pinpoint the cause and implement a resolution. We understand the potential impact on your business and are committed to restoring full functionality as swiftly as possible. We will provide further updates once the solution is in place. Thank you for your patience and understanding.
Posted Aug 01, 2025 - 19:34 UTC
This incident affected: XDR (XDR Service).