Cloud-to-Cloud Backup slowness

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Mar 20, 2026 - 18:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 20, 2026 - 13:55 UTC

Investigating

We are investigating an issue with Cloud-to-Cloud Backup that is causing long-running backup jobs and user interface slowness.
Posted Mar 20, 2026 - 12:39 UTC
This incident affected: Cloud to Cloud Backup (Web Interface, Cloud to Cloud Backups).