Incident Response: Degraded Perfomance

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Aug 04, 2026 - 13:56 UTC

Update

The system is stable and recovered. We will continue to monitor for the next several hours.
Posted Aug 04, 2026 - 00:15 UTC

Monitoring

Attempting to creating a new incident could result in a longer than usual "pending creation" state. We have identified the issue, implemented a fix, and are monitoring the solution. Thank you for your patience as the system continues to recover.
Posted Aug 03, 2026 - 20:56 UTC
This incident affected: Incident Response (Dashboard UI, Email Processing).