XDR Service - Maintenance

Incident Report for Barracuda Networks

Resolved

Our SOC has concluded maintenance, and there is no longer a delay in Automated Threat Response component for Microsoft 365
Posted Apr 14, 2025 - 14:12 UTC

Update

Our SOC is continuing to monitor this scheduled maintenance on Impossible Travel and Anomalous Login detection models for Microsoft 365. During this time, there may be temporary delays (less then 1 hour) in the Automated Threat Respone component for a subset of alerts related to these use cases.
Posted Apr 09, 2025 - 22:30 UTC

Monitoring

Barracuda XDR SOC is currently performing scheduled maintenance on our Impossible Travel and Anomalous Login detection systems for Microsoft 365. During this time, there may be temporary delays in alerting for a subset of detections related to these use cases.
Maintenance Window: Now through April 14th
We are working to complete the maintenance as swiftly as possible and appreciate your patience and understanding. If you have any questions or require urgent assistance, please reach out to our SOC team at soc@barracuda.com
Posted Apr 09, 2025 - 21:38 UTC
This incident affected: XDR (XDR Service).