Barracuda Cloud Archiving (BCAS) - Web Interface - Inoperable Search in EU and Australia

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 20:14 UTC

Monitoring

The issue has been resolved. We are monitoring the system. Thank you for your patience as the system recovers.
Posted Jul 29, 2025 - 19:19 UTC

Identified

We are investigating an issue that is affecting the web interface in the EU and AU regions. We are working to resolve the issue. Search queries may be inoperable until this issue is resolved.
Posted Jul 29, 2025 - 14:31 UTC
This incident affected: Cloud Archiving Service (Web Interface).