Barracuda XDR - Dashboard Planned Maintenance Outage

Incident Report for Barracuda Networks

Resolved

XDR Dashboard is fully operational. This maintenance affected only the dashboard. The XDR service / SOC (monitoring, alerting, remediation) was not affected during this maintenance activity. We recommend users to logout and log back in for clearing stale session in the browser. Appreciate your patience and co-operation during this unforeseen extended window of maintenance.
Posted Mar 31, 2025 - 17:02 UTC

Update

XDR Dashboard maintenance is still in progress and has delayed due to Cloud rate limits. 65% migration has been completed. Next update by 1 PM EDT.
Posted Mar 31, 2025 - 16:32 UTC

Investigating

Barracuda XDR dashboard will be experiencing a minor outage for an hour (starting 10 AM EDT) when we rollout the latest release to enhance the self-service functionality. We understand the impact this may have on your business and our engineering team is committed to restoring the dashboard as quickly as possible.
The core XDR service is not affected. Data is still flowing into XDR and the SOC systems are fully operational. We will provide another update once the deployment is complete and the dashboard is back online.
When the dashboard is operational - we recommend users to logout and log back in.
Posted Mar 31, 2025 - 13:23 UTC
This incident affected: XDR (XDR Dashboard).