BarracudaONE Service Degradation

Incident Report for Barracuda Networks

Resolved

This incident has been resolved.
Posted Sep 26, 2025 - 16:55 UTC

Investigating

We are currently investigating an issue causing product and protection summary information to fail to load in the BarracudaONE home page.
Posted Sep 26, 2025 - 13:26 UTC
This incident affected: BarracudaONE (BarracudaONE Web App).