XDR Service Interruption

Incident Report for Barracuda Networks

Monitoring

Our engineering team has implemented a solution to resolve this issue. We will continue to monitor to ensure the impacted process is fully operational.
Posted Apr 24, 2025 - 14:27 UTC

Identified

Barracuda XDR is currently experiencing an issue in the o365 events ingestion, only in US region, which could result in delayed ingestion. Our engineers are actively working on resolving this service issue. We understand the impact this may have on your business and are committed to restoring full functionality as quickly as possible.
We will provide further updates as we implement a solution to bring this service fully operational
Posted Apr 24, 2025 - 12:03 UTC
This incident affects: XDR (XDR Service).