Barracuda Cloud-to-Cloud Backup - Degraded Backup Speeds (UK Region)
Incident Report for Barracuda Networks
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 22:24 UTC
Update
Microsoft is now implementing a fix for this issue, and we are seeing improvements in backup speeds. We will provide another update when this is fully mitigated.
Posted Feb 27, 2024 - 16:54 UTC
Identified
We have identified an issue causing slower backups for some customers in the UK South region, and are awaiting a fix from Microsoft to remediate this issue.
Posted Feb 26, 2024 - 16:42 UTC
This incident affected: Cloud to Cloud Backup (Cloud to Cloud Backups).