O365 log ingestion issue impacting some accounts with delay and log degradation alerts.

Incident Report for Barracuda Networks

Monitoring

Backlogs have been processed and we are verifying recovery is complete
Posted Sep 19, 2026 - 12:35 UTC

Identified

Microsoft had a service issue on Sept-13 under advisory [MO1471241] which caused a backlog of logs.  After restoration of MS service, the age and volumes of logs caused complications for XDR backend processing. Processing is now recovering. Affected customers may receive alerts based on older data.
Posted Sep 18, 2026 - 18:26 UTC

Investigating

We are experiencing an O365 log ingestion issue impacting some proportion of accounts.  The affected customers have not receiving logs for the past 3 days and are seeing log degradation tickets.  SRE and Data Engineering teams are actively troubleshooting the issue.
Posted Sep 18, 2026 - 15:49 UTC
This incident affects: XDR (XDR Service).