Support Phone System Outage

Incident Report for Barracuda Networks

Resolved

Resolved: Our Phone Provider has indicated their services are stabilizing. The Support team has tested and validated that we are once again able to receive inbound phone calls as well as make outbound phone calls, confirming that at this time our phone system is fully operational.
Posted Apr 17, 2025 - 00:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 16, 2025 - 20:45 UTC

Update

We are continuing to work on a fix for this issue.
Posted Apr 16, 2025 - 20:05 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Apr 16, 2025 - 20:05 UTC

Investigating

Due to a current global outage with our phone provider, the Barracuda support team is experiencing an issue impacting our phone system and is currently unable to make or receive phone calls. For the time being, we encourage our customers to reach out for Support by emailing support@barracuda.com. Our team is currently monitoring the situation and working with our phone provider to restore the service. We will provide further updates as soon as they become available.
Posted Apr 16, 2025 - 20:05 UTC
This incident affected: Support Phone System.