XDR Service Disruption

Incident Report for Barracuda Networks

Resolved

Our team has identified the cause of this issue and has implemented a solution. At this time, the issue is resolved.

As noted in the previous update, some recent emails failed to be delivered to the SOC. If you are awaiting a response from the SOC on a request you've submitted recently, it is likely that the message failed. We are actively working to restore as many failed messages as possible. However, for these cases, we encourage customers to either re-send the email at this time or call the SOC at 855-838-4500 for faster responses. Thank you
Posted Nov 28, 2023 - 16:45 UTC

Investigating

Barracuda XDR is currently experiencing an issue with emails sent from our customers to the SOC at soc@barracuda.com. The issue is preventing these messages from reaching our ticketing system. Therefore, customers will experience delayed response times when attempting to contact the SOC via this email address. For any urgent matters, please contact the SOC via phone at 855-838-4500 or using our legacy email address soc@skoutsecure.com - either of these options will successfully connect you with the SOC.

Our engineers are currently working to identify the cause and get the issue resolved as quickly as possible. We will provide another update once the issue has been identified and we have started to implement a solution.
Posted Nov 28, 2023 - 15:05 UTC
This incident affected: XDR (XDR Service).